Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004460 [Squeak] Sound crash always 08-09-06 18:44 08-29-06 20:41
Reporter Laurence Rozier View Status public  
Assigned To
Priority normal Resolution open Platform
Status new   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.8
  Product Build
Summary 0004460: randomBitsFromSoundInput: causes crash
Description SoundService default randomBitsFromSoundInput: 512
causes the image to crash under OS/X 10.4 and nothing is written to the debug log.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0006441 - 463 - 539 - 539 - 539 - 539 - 539)
wiz
08-10-06 05:28

another data point

outputs fine for me.

SoundService default randomBitsFromSoundInput: 512
" 2721824090667625240012497281187916366542162067315899532304113575067286432320248950537758982410810884747201471742875556287977939587044841156676081548226263"

I am using sq7051r (the most recent one r is for revision) on a iMac under os9.1 with a SqVm3.8.9b7.

So someone needs to verify the problem in your configuratioin.

Yours in service, -- Jerome Peace
 
(0006460 - 82 - 82 - 82 - 82 - 82 - 82)
johnmci
08-10-06 19:09

Need to know which VM this is with, works fine with a mac carbon os-x 3.8.12b4U VM
 
(0006489 - 61 - 61 - 61 - 61 - 61 - 61)
Laurence Rozier
08-11-06 15:27

The VM is Squeak 3.8.12beta4U and the image is Squeak3.8-6665
 
(0006548 - 86 - 92 - 92 - 92 - 92 - 92)
johnmci
08-13-06 01:38

Need to have the crash log.
See ~/Library/Logs/CrashReporter/Squeak VM Opt.crash.log
 
(0006551 - 407 - 527 - 527 - 527 - 527 - 527)
Laurence Rozier
08-13-06 02:44
edited on: 08-13-06 02:45

**********

Host Name: GVM
Date/Time: 2006-08-11 09:29:41.684 -0400
OS Version: 10.4.7 (Build 8J135)
Report Version: 4

Command: Squeak VM Opt
Path: /Applications/Squeak3.8-MacOS-Full/Squeak 3.8.12beta4U.app/Contents/MacOS/Squeak VM Opt
Parent: WindowServer [66]

Version: Squeak VM 3.8.12b4 (3.8.12b4)

PID: 2436
Thread: Unknown

Link (dyld) error:

image not found

 
(0006810 - 450 - 502 - 502 - 502 - 502 - 502)
johnmci
08-29-06 20:41

Ok, if this is repeatable you must then invoke the binary via gnu debug
gdb . to do this you open a terminal session and cd down to the binary in the squeak.app, then invoke gdb against the binary, and say run. When it crashes do a backtrace and do "call (int) printAllStacks()"

so we can see what is failing. I have noticed recently that it does
Link (dyld) error:
image not found

and does not print the reason why, unless you invoke gdb
 

- Issue History
Date Modified Username Field Change
08-09-06 18:44 Laurence Rozier New Issue
08-10-06 05:28 wiz Note Added: 0006441
08-10-06 19:09 johnmci Note Added: 0006460
08-11-06 15:27 Laurence Rozier Note Added: 0006489
08-13-06 01:38 johnmci Note Added: 0006548
08-13-06 02:44 Laurence Rozier Note Added: 0006551
08-13-06 02:45 Laurence Rozier Note Edited: 0006551
08-29-06 20:41 johnmci Note Added: 0006810


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker